Zendesk Chat Requirements

Chat widget (visitor requirements):

  • Desktop:
    • Google Chrome v.25 and higher
    • Mozilla Firefox v.21 and higher
    • Apple Safari v.6 and higher
    • Microsoft Edge
    • Microsoft Internet Explorer v. 11
  • Mobile:
    • latest two major versions of Safari on iOS
    • latest version of Chrome on iOS
    • latest two major versions of Chrome on Android
    • latest version of Firefox on Android
Read additional information HERE.

Windows browser update links are below: